[Swan-dev] rename ip_subnet to ip_selector
andrew.cagney at gmail.com
Wed Feb 19 15:12:28 UTC 2020
Per comment in ip_subnet.h:
* This is not the subnet you're looking for.
* In libreswan ip_subnet is used to store client routing information.
* IKEv2 calls this traffic selectors and it allows the negotiation
* LO_ADDRESS..HI_ADDRESS : LO_PORT..HI_PORT
* The structures below can only handle a limited subset of this,
* NETWORK_PREFIX | 0 / MASK : PORT
* where PORT==0 imples 0..65535, and (presumably) port can only be
* non-zero when the NETWORK_PREFIX/MASK is for a single address.
since most code is using ip_subnet as a selector/filter.
We've then got space for an ip_subnet type.
More information about the Swan-dev