[Swan-dev] rename .st_msgid -> .st_v1_msgid or .v1st_msgid
paul at nohats.ca
Thu Oct 18 15:03:18 UTC 2018
On Thu, 18 Oct 2018, Andrew Cagney wrote:
> Given this, I'm planning on renaming .st_msgid (and likely the above).
> Since we've settled on v* as the name prefix convention several
> new names come to mind:
> - st_v1_msgid
> - v1st_msgid
> - v1_st_msgid
> any preference? The st_msgid_* fields listed above will also get a
> rename, but one that also adds responder/initiator.
All variables inside struct state have a st_ prefix. Please keep that
prefix. so st_v1_msgid is fine.
> (PS: I've also a strong preference for sticking v2 somewhere in any
> v2-only thing as that way I know it isn't generic and may have to
> handle ikev1)
Fine with me.
More information about the Swan-dev