[Swan-dev] spacers in flag names: - or _?
D. Hugh Redelmeier
hugh at mimosa.com
Mon Apr 14 08:42:20 EEST 2014
| From: Paul Wouters <paul at vault.libreswan.fi>
| commit a0f5b2688533d43556655200e501e72a17a4b957
| Author: Paul Wouters <pwouters at redhat.com>
| Date: Sun Apr 13 19:50:19 2014 -0400
| pluto: turn -DLEAK_DETECTIVE into runtime --leak_detective option.
Most flags that need a spacer use "-". Some newer ones use "_". This
is confusing and non-standard.
I checked the pluto flags (not whack or anything else)
- 43 use "-"
- 10 use "_"
- debug-nat_t is in both counts.
I think that "normal" programs use "-".
I propose that all spacers within flags be "-".
Here's what would change:
keep_alive <<== should agree
force_keepalive <== on spelling of keep alive
More information about the Swan-dev