[Swan] VPN server on Debian 10 using L2TP with IPSEC PSK not working

Mirsad Goran Todorovac mirsad.todorovac at alu.hr
Mon Nov 22 17:24:26 EET 2021

Dear Sir or Madam,

I am having a problem setting up VPN on Debian server 10 for our 
Microsoft and Android clients to connect. Our current configuration is 
L2TP over IPSEC with PSK, as it is also supported on our UniFi UDM-Pro 

I have explained the problem here, but I've received no reply yet:


Please help me with this configuration, as it would be very good that it 
worked for the "road warriors" now in these COVID situations and work 
from home.

UniFi UDM configuration worked "out of the box" from the GUI interface, 
but I am perplexed with the number of various configuration options of 
libreswan, ipsec and xl2tpd. I've used an example from Github, but it 
didn't work well with my server (it stopped postfix local delivery 

Thank you very much in forward.

Best regards,
Mirsad Todorovac

Mirsad Goran Todorovac
CARNet sistem inženjer
Grafički fakultet | Akademija likovnih umjetnosti
Sveučilište u Zagrebu
CARNet system engineer
Faculty of Graphic Arts | Academy of Fine Arts
University of Zagreb, Republic of Croatia
tel. +385 (0)1 3711 451
mob. +385 91 57 88 355

More information about the Swan mailing list