[Swan] Errors while installing libreswan

JAIN Sejal Sejal.JAIN at cea.fr
Fri Feb 1 12:54:16 UTC 2019

Thanks for your reply.
Make deb worked but now the commands that are given in the README.md file are not working. Like there are some errors which running make all, make install, make base and that is why I am unable to install IPSec program. 
These are the errors:
"//usr/lib/x86_64-linux-gnu/liblber-2.4.so.2: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
../../mk/program.mk:121: recipe for target 'pluto' failed
make[3]: *** [pluto] Error 1
../../mk/targets.mk:82: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/home/lab1/libreswan-3.27/programs/pluto'
../mk/targets.mk:82: recipe for target 'recursive-all' failed
make[1]: *** [recursive-all] Error 2
make[1]: Leaving directory '/home/lab1/libreswan-3.27/programs'
mk/targets.mk:82: recipe for target 'recursive-all' failed
make: *** [recursive-all] Error 2"

I am not able to figure out what is the problem.
Could you please guide me.
Thanks for your help. Hope to hear from you soon.
Kind Regards,
From: Paul Wouters [paul at nohats.ca]
Sent: Tuesday, January 29, 2019 6:13 PM
To: JAIN Sejal
Cc: swan at lists.libreswan.org
Subject: Re: [Swan] Errors while installing libreswan

On Mon, 28 Jan 2019, SJ257432 wrote:

> I have tried with your steps. I replicated them but still getting the same
> error as earlier: "error: field ‘v6’ has incomplete type
>    struct sockaddr_in6 v6; "

I don't know how to help you further. I already downloaded the ISO
matching your OS, and installed it and described the steps. The only
possibly remote thing that it could be is that I ran rm -rf OBJ* between
compile attempts.


More information about the Swan mailing list