<div dir="ltr"><br><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Would renaming it "delta_less" help?  Does that make it two chunks<br>
cognitively?  deltatimeless is pretty undigestible.  "before" is a<br>
really nice name but it doesn't flag what kind of time is being<br>
considered.  Maybe "sooner" is better considering that deltatimes are<br>
(I think) normally in the future).  Naming is important and tricky.<br>
<br></blockquote><div><br></div><div>The more I look at this code the more I think deltatime_t should be reduce to:<br></div><div><br></div><div>   typedef struct { intmax_t ns; } deltatime_t;</div><div><br></div><div>and we simply accept that .ms (milliseconds; 1/1000s) is "public" so that:<br></div><div><br></div><div>   deltatime_t f(deltatime_t a, deltatime b) {<br></div><div>      if (<a href="http://a.ms">a.ms</a> > <a href="http://b.ms">b.ms</a>) ...</div><div>      return deltatime_ms(<a href="http://a.ms">a.ms</a> + <a href="http://b.ms">b.ms</a>);</div><div>  }<br></div><div><br></div><div>is acceptable.</div><div><br></div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
My suggestion: keep deltaless (however spelled (but not dataless)).<br>
Rewrite individual calls if and only if it improves readability.  New<br>
calls should use the most readable.  See where we get after a suitable<br>
period.<br>
<div class="HOEnZb"><div class="h5">______________________________<wbr>_________________<br>
Swan-dev mailing list<br>
<a href="mailto:Swan-dev@lists.libreswan.org">Swan-dev@lists.libreswan.org</a><br>
<a href="https://lists.libreswan.org/mailman/listinfo/swan-dev" rel="noreferrer" target="_blank">https://lists.libreswan.org/<wbr>mailman/listinfo/swan-dev</a><br>
</div></div></blockquote></div><br></div></div>