[Swan-dev] "policy" is an overused word
andrew.cagney at gmail.com
Wed Jun 16 20:49:48 UTC 2021
On Wed, 16 Jun 2021 at 16:03, D. Hugh Redelmeier <hugh at mimosa.com> wrote:
> I see some functions have been renamed with "policy" replacing "eroute".
shunt_policy(), raw_policy(), enum kernel_policy to be exact.
> The trouble with "policy" is that it is used to label way too many things
> in networking (and the rest of the computer field). It isn't that the
> word is inappropriate, but that the word retains no specificity.
> I strongly suggest we not add to this problem.
I think it is better than eroute:
- I run <<ip xfrm policy>> or <<setkey -DP>> to Dump Policies
- I can find policy in the RFCs (technically Security Policy Database) and
but yes, given connection.policy, it isn't ideal.
> Swan-dev mailing list
> Swan-dev at lists.libreswan.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Swan-dev