[Swan-dev] ikev2_hash_algorithm , was Fwd: [Swan-commit] Changes to ref refs/heads/master
paul at nohats.ca
Mon Mar 9 16:05:39 UTC 2020
Begin forwarded message:
> From: Andrew Cagney <cagney at vault.libreswan.fi>
> Date: March 9, 2020 at 11:32:17 EDT
> To: swan-commit at lists.libreswan.org
> Subject: [Swan-commit] Changes to ref refs/heads/master
> Reply-To: swan-dev at lists.libreswan.org
> New commits:
> commit 7a7224b0e2381c416decb1d08bc191cd9fd783f1
> Author: Andrew Cagney <cagney at gnu.org>
> Date: Mon Mar 9 11:27:01 2020 -0400
> ikev2: rename enum notify_payload_hash_algorithms to enum ikev2_hash_algorithm
This is confusing. We have an IANA registry for ikev2 hash (integ) algorithms and this is not it.
The first is a transform type, the second is a notify value. Better name would be ikev2_rfc7427_hash_algo ?
I fear ikev2_hash_algorithm is prone to be misused as a transform value.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Swan-dev