[Swan-dev] testing hangs for me

D. Hugh Redelmeier hugh at mimosa.com
Wed Mar 13 14:57:12 UTC 2019

| From: Andrew Cagney <andrew.cagney at gmail.com>
| Date: Tue, 12 Mar 2019 14:35:53 -0400

| On Thu, 7 Mar 2019 at 10:00, Andrew Cagney <andrew.cagney at gmail.com> wrote:
| >
| > Hugh,

Sorry for the slow response.  Thanks for working on this.

| > The testing machine might be hitting this problem (yesterday it hung
| > twice) so I crippled it.
| >
| > On the machine that hangs, have you tried a run with KVM_WORKERS unset
| > and/or KVM_PREFIXES with only one entry?

No, I haven't run any tests recently.  If I were on the ball, I would
have tried your suggestion, but I have not.

I have two test machines that are useless because of this problem, but
I have two other test machines that work because they have
not-recently-updated Fedora 29.

| Well that just made everything (including the time between hangs) slower ....
| Next I'm trying:
|    dnf downgrade python3
| ...

Thanks for plugging away at this.

Were you able to figure out anything from the entrails of a hung run?

I guess it should be possible to bisect this by applying upgrades in
varying amounts, but that sure seems tedious.

I did try booting an older kernel when this first showed up, and that
didn't fix things.  So that is evidence the problem isn't in the
update kernel itself.  But do take that with reservations.

More information about the Swan-dev mailing list