[Swan-dev] testing libipsecconf

D. Hugh Redelmeier hugh at mimosa.com
Wed Nov 26 01:14:58 EET 2014

[tl;dr] see my actual questions, highlighted with ==>

I started to look at libipsecconf because Paul asked me to look at a 
couple of small patch to it.

One thing has lead to a lot of others.  Like "improving" the parser.l and 

Now I need to test if my changes are sound.  So I want to use 

==> Do these tests actually run in "make check"?  They don't seem to in mine.

I want to test them on my desktop machine.  It doesn't have all the
KVM paraphernalia.  But I would think that that ought to be OK for
testing scripts.

In libreswan/testing/scripts/readwriteconf-01/, I try running
    ROOTDIR=/home/hugh/libreswan-archive/libreswan \
    OBJDIRTOP=/home/hugh/libreswan-archive/libreswan/OBJ.linux.x86_64 \
    sh -xue runit.sh

but that fails with:
	warning: could not open include filename: '/testing/baseconfigs/all/etc/ipsec.d/ipsec.conf.common' (tried /home/hugh/libreswan-archive/libreswan/testing/baseconfigs/all/testing/baseconfigs/all/etc/ipsec.d/ipsec.conf.common and )

That message could be improved (and I have).  It means that no file was found at:

The file is actually at:

So we have an extra bit in the middle:

I can get rid of this problem by changing testing/scripts/readwriteconf-01/runit.sh:
-args="--rootdir=$ROOTDIR/testing/baseconfigs/all --config $ROOTDIR/testing/baseconfigs/west/etc/ipsec.conf --verbose --verbose"
+args="--rootdir=$ROOTDIR --config $ROOTDIR/testing/baseconfigs/west/etc/ipsec.conf --verbose --verbose"
This line dates back to 2006 October 11

==> Is this only a problem in my context?
==> Has this test ever worked?
==> Is these something wrong with my fix to runit.sh?

==> what is the best way of testing libipsecconf changes?

More information about the Swan-dev mailing list