[Swan-dev] test suite didn't start at the beginning -- why?

D. Hugh Redelmeier hugh at mimosa.com
Sun Aug 17 10:27:47 EEST 2014

I ran the test suite about an hour ago.
I noticed that I'd introduced a bug.
I killed the test suite.
I fixed the bug.
I rebuilt libreswan and installed it on all the VMs.
I ran one of the tests that failed, confirming that my fix worked.
So I ran the test suite again.

For some reason, it picked up in the middle.  The first test it ran
was ikev2-11-simple-psk
This is certainly not what I want.

I take it that this is a feature because it must have taken work to
make it work this way.

Why is this a feature?  Can I get the behaviour I want?

(I see in the console output

INFO:root:** found file ./TESTLIST **
INFO:root:testresult directory /home/build/results exist
INFO:root:sub directory /home/build/results/2014-08-17 exist

I'm going to delete that result file to see if the thing starts doing
what I want.

I'd expect to be able to run the tests multiple times a day but this
filename suggests that I'd be wrong.

Oh, and why does the makefile think it has the right to use ~/results?
All my libreswan stuff is supposed to be within a subtree ~/libreswan.

More information about the Swan-dev mailing list